Solve Problem TypeError: sequence index must be integer, not ‘slice’

Beberapa waktu lalu saya memiliki permasalahan untuk koneksi ke database postgresql dengan muncul error message : TypeError: sequence index must be integer, not ‘slice’ . Error ini terjadi apabila kalian menggunakan database postgresql dengan menggunakan koneksi psycopg2. Kesalahan ini terjadi ketika versi django, python, psycopg dan psycopg-binary nya tidak saling compatible versioningnya. Disini saya ingin share …

Cara Membuka Port di CentOS 7 dengan Firewalld

CentOs salah satu OS yang sangat memperhatikan sistem keamanan, maka kerap kali centOs sangat banyak diminati untuk keperluan server. Disini saya terbiasa melakukan development dan production untuk aplikasi yang saya ciptakan untuk di install di server centOs. Salah satunya adalah pengaturan akses port. Bisa jadi apabila kalian membuat sebuah protokol misalkan dengan port 8080 atau …

Install NPM Unmet Dependencies

Pernah kalian mengalami error seperti dibawah ini ketika hendak menginstall NPM (sudo apt install npm) ? Disini sebelumnya saya sudah menginstall nodeJs, tetapi ketika saya hendak menginstall npm terjadilah error seperti dibawah ini The following packages have unmet dependencies: npm : Depends: node-gyp (>= 0.10.9) but it is not going to be installed E: Unable …

Install WpScan Tool di Ubuntu / Mint

Saya tidak menjelaskan apa itu wpscan tool dan tidak menjelaskan fungsi dari tools ini untuk apa. Di sini saya hanya share mengenai cara installasi WpScan Tool ini, tool ini biasanya default tersedia di OS Kali Linux atau dulu disebut dengan Backtrack. sudo apt-get install libcurl4-openssl-dev libxml2 libxml2-dev libxslt1-dev ruby-dev build-essential libgmp-dev zlib1g-dev sudo apt-get install …

Error Push Gitlab Bad owner or permissions and Please make sure you have the correct access rights

Pernah kalian menemukan error seperti ini ketika hendak mengupdate source kalian ke gitlab ? disini saya mengalaminya dan sudah solve probelm. Arti dari error tersebut adalah Bad owner or permissions on /home/mhafid/.ssh/config fatal: Could not read from remote repository. Please make sure you have the correct access rights bahwa folder .ssh yang didalamnya ada config …

Installasi Pip dan VirtualEnv Linux Mint

Halo bro, disini saya hanya sekedar ingin mencatat cara installasi virtualenv untuk kebutuhan developer saya, saya kebetulan menggunakan OS Linux Mint dengan versi python terinstall 2.7 dan 3.5.2. Saya menggunakan Virtualenv untuk kebutuhan coding dengan menggunakan python variant version. Sekarang kalian buka console dan installasi pip terlebih dahulu dengan cara : sudo apt-get install python3-pip …

Error Gconf2 Upgrade Linux Mint 19.1

Halo sobat pecinta linux, disini saya baru saja mengupgrade versi linux mint saya dari versi 18 ke versi 19.1. Saya melakukan fresh installasi ke versi 19.1 karena saya sudah mencoba untuk melakukannya tanpa fresh install dengan menggunakan dist upgrade misalkan, tidak berhasil. Yang menjadi permasalahan disini adalah, ketika selesai melakukan upgrade linux mint, (apt upgrade) …