Install NPM Unmet Dependencies

Pernah kalian mengalami error seperti dibawah ini ketika hendak menginstall NPM (sudo apt install npm) ? Disini sebelumnya saya sudah menginstall nodeJs, tetapi ketika saya hendak menginstall npm terjadilah error seperti dibawah ini

The following packages have unmet dependencies: npm : Depends: node-gyp (>= 0.10.9) but it is not going to be installed E: Unable to correct problems, you have held broken packages.

Solusinya adalah hapus terlebih dahulu nodeJs yang sudah terinstall.

sudo apt-get purge –auto-remove nodejs

Setelah itu install paket dibawah ini

sudo apt-get install nodejs-dev node-gyp libssl1.0-dev

Setelah itu install npm nya

sudo apt-get install npm

Semoga berhasil

Leave a Reply

Your email address will not be published. Required fields are marked *