Mengatasi Masalah “pg_dump: aborting because of server version mismatch”

Kalian pasti mengetahui pg_dump itu berfungsi untuk apa ? pg_dump berfungsi untuk backup database postgresql. Disini saya memiliki permasalahan dengan muncul pesan error seperti dibawah ini :

pg_dump: server version: 10.12; pg_dump version: 9.2.24
pg_dump: aborting because of server version mismatch

Artinya adalah bahwa versi pg_dump tidak support dengan versi postgresql yang digunakan yaitu versi 10.12. Jadi cara untuk menyelesaikan masalah ini adalah melakukan link / ln pg_dump ke postgresql versi 10 :

Lakukan scanning dengan mengetikan perintah :

find / -name pg_dump -type f 2>/dev/null

Outputnya adalah :

/usr/bin/pg_dump
/usr/pgsql-10/bin/pg_dump

Langkah selanjutnya adalah :

sudo ln -s /usr/pgsql-10/bin/pg_dump /usr/bin/pg_dump –force

Sekarang lakukan backup database dengan pg_dump, dijamin akan berhasil dan berjalan.

pg_dump -U postgres namadatabase > namadatabaseingindisimpan.sql

Author: Hafid

Hi! My name is Hafid and I'm Indonesian DKI Jakarta. Here's my profile www.mhafid.com. In here, I share a lot of information about programming and linux there.

Leave a Reply

Your email address will not be published. Required fields are marked *