NPM Install ERR / Error

Pernah mengalami error seperti dibawah ini, pada saat install sudo npm install -g grunt-cli bower ?

npm WARN unmet dependency /usr/lib/node_modules/npm/node_modules/npm-package-arg requires semver@’4′ but will load
npm WARN unmet dependency /usr/lib/node_modules/npm/node_modules/semver,
npm WARN unmet dependency which is version 2.3.0

Pada tutorial ini saya menggunakan ubuntu versi14.00, sebaiknya buka file yang bernama package.json di folder home, lalu hapus semua isinya dan rubah menjadi :

{
  “name”: “my-super-amazing-app”,
  “version”: “1.0.0”,
  “private”: true
}

Lalu save dan jalankan lagi command  sudo npm install -g grunt-cli bower, dan hasilnya yang tampil di console saya adalah :

> appjs@0.0.20 postinstall /home/hafid/node_modules/appjs
> node cli/postinstall.js
Installing appjs-linux-x64 package…

Sumber : http://stackoverflow.com/questions/16827858/npm-warn-package-json-no-repository-field

Leave a Reply

Your email address will not be published. Required fields are marked *