PG_DUMP Aborting Because of Server Version Mismatch

Pernah kah anda mengalami error semacam ini ? tidak bisa melakukan backup database. Ada kemungkinan pg_dump yang di install tidak sama dengan postgresql yang di install. Maka solusinya adalah mencari pgdump yang ada pada server dengan cara :

find / -name pg_dump -type f 2>/dev/null

Gunakan path yang ada pgsql versionnya misalkan /usr/pgsql-10/bin/pg_dump lalu lanjutkan dengan script dump sql, lengkapnya adalah sebagai berikut :

/usr/pgsql-10/bin/pg_dump -h localhost -U postgres namadatabase > namabackup.sql

semoga berhasil.

Author: Hafid

Hi! My name is Hafid and I'm Indonesian DKI Jakarta. Here's my profile www.mhafid.com. In here, I share a lot of information about programming and linux there.

Leave a Reply

Your email address will not be published. Required fields are marked *